Ga Terug  
     


Notities

Lounge De Joomla lounge.

Antwoord
 
Onderwerpopties Weergavemodus
Oud 1 juli 2016, 22:58   #1
Ranger
 
Ranger's Avatar
 
Geregistreerd op: 13 mei 2010
Berichten: 120
Bedankjes gegeven: 12
Bedankjes ontvangen: 5
Question PHP 7.0 of PHP 5.6?

Volgens mijn Ubuntu VPS zou de php versie 7.0 moeten zijn. (Backend)
Volgens de phpinfo.php file zou ik php 5.6.23 gebruiken. Ook mijn Joomla site zegt dit.

Wat moet ik doen om php.ini ook naar de huidige versie van php te laten verwijzen? Ik bedoel, als ik in de VPS het commando php -v geef is het antwoord 7.0. Dus gebruikt mijn VPS versie 7.0 toch?

Joomla! gebruiker sinds versie 1.5.0
wijwilleneenjoomlawebsite.nl
Ranger is offline   Met citaat antwoorden
Oud 3 juli 2016, 09:44   #2
MartijnM
Taalteam
 
MartijnM's Avatar
 
Geregistreerd op: 1 oktober 2008
Locatie: Utrecht
Leeftijd: 64
Berichten: 2.728
Bedankjes gegeven: 303
Bedankjes ontvangen: 751
Standaard Re: PHP 7.0 of PHP 5.6?

Cache geschoond in Joomla?

Groet,
Martijn www.reisverslagen.net
Niets is zeker en zelfs dat niet.
Alles kan, alleen het onmogelijke duurt iets langer.
MartijnM is offline   Met citaat antwoorden
Oud 3 juli 2016, 14:06   #3
Ranger
 
Ranger's Avatar
 
Geregistreerd op: 13 mei 2010
Berichten: 120
Bedankjes gegeven: 12
Bedankjes ontvangen: 5
Standaard Re: PHP 7.0 of PHP 5.6?

Heb ik gedaan geen verschil hij geeft nog steeds PHP 5.6.23 aan als php versie.

Joomla! gebruiker sinds versie 1.5.0
wijwilleneenjoomlawebsite.nl
Ranger is offline   Met citaat antwoorden
Oud 3 juli 2016, 17:40   #4
n9iels
 
n9iels's Avatar
 
Geregistreerd op: 2 januari 2012
Locatie: Gouda
Leeftijd: 20
Berichten: 495
Bedankjes gegeven: 13
Bedankjes ontvangen: 96
Standaard Re: PHP 7.0 of PHP 5.6?

Wellicht dat apache nog ingesteld staat op PHP 5.6? Dacht dat je dat per apache site kon aangegeven.

n9iels is offline Stuur een bericht via Skype™ naar n9iels   Met citaat antwoorden
Oud 3 juli 2016, 18:32   #5
Ranger
 
Ranger's Avatar
 
Geregistreerd op: 13 mei 2010
Berichten: 120
Bedankjes gegeven: 12
Bedankjes ontvangen: 5
Standaard Re: PHP 7.0 of PHP 5.6?

De manier om php 7.0's php.ini bestand te activeren is:
sudo a2dismod php5.6
sudo a2enmod php7.0
sudo service apache2 restart.

Dit heb ik gedaan maar toen deden mijn Joomla websites het niet meer! Ergens op internet vond ik: Let op: PHP 7 werkt alleen met Joomla! 3.5 en later. Zolang je nog blijft werken met Joomla! 3.4.8 is het nog niet mogelijk om al over te schakelen naar PHP 7.

Gelukkig wordt php5.6 nog 2 jaar ondersteund.

Joomla! gebruiker sinds versie 1.5.0
wijwilleneenjoomlawebsite.nl
Ranger is offline   Met citaat antwoorden
Oud 6 juli 2016, 11:04   #6
hvdmeer
Moderatorteam
Gebruikersgroep Arnhem & Nijmegen
 
hvdmeer's Avatar
 
Geregistreerd op: 21 februari 2009
Locatie: Arnhem
Berichten: 3.161
Bedankjes gegeven: 108
Bedankjes ontvangen: 432
Standaard Re: PHP 7.0 of PHP 5.6?

Klopt, staat inderdaad bij de aankondiging van deze Joomla. Dus eerst Joomla naar 3.5.1 updaten en daarna pas PHP7 activeren.
Is dit topic dan nu in zoverre opgelost?

J! doc-vertaler, J! patch tester, JUG-organisator, moderator
Eigen site: http://www.hierbenikthuis.nl en van mijn loopgroep: http://www.loopgroep-arnhemia.nl
Beetje over mij: http://hierbenikthuis.nl/prive/over-mij
Reageert op DM alleen op zaken die niet op het forum geplaatst kunnen worden.
hvdmeer is offline Stuur een bericht via Skype™ naar hvdmeer   Met citaat antwoorden
Antwoord

Onderwerpopties
Weergavemodus

Berichting Regels
Je mag niet nieuwe onderwerpen maken
Je mag niet reageren op berichten
Je mag niet bijlagen posten
Je mag niet je berichten bewerken

BB code is Aan
Smilies zijn Aan
[IMG] code is Aan
HTML code is Uit

Forumnavigatie


Alle tijden zijn GMT +1. De tijd is nu 03:17.